I just met a new problem that seems very hard to solve. In our project we have dependencies to asm 1.5.3 and parboiled needs asm 3.3.1. Our asm cannot be upgraded due to to high difference of version. Is there any solution for this?
Hmm… the latest versions of parboiled actually depend on ASM 4.0 or 4.1.
ASM 1.5.3 appears to be _reaally_ old.
Since ASM is a pretty hard dependency of parboiled-java there is little way around it.
You _can_, if you must, run parboiled without parser extension and therefore without ASM.
However, this means that you loose everything that parser extension gives you, i.e.:
recursion support, implicit parser actions, annotation support, and so on.
You can only work with explicit parser actions (i.e. anonymous inner classes for the most part) and so on.
In larger parser this is quite a pain and not exactly great for readability and/or maintenance.
If you must use java (and cannot rely on parboiled-scala for example, which doesn't require ASM) unfortunately you are stuck.
On 03.12.2012, at 16:59, "cosmindumy [via parboiled users]" <[hidden email]> wrote:
> I just met a new problem that seems very hard to solve. In our project we have dependencies to asm 1.5.3 and parboiled needs asm 3.3.1. Our asm cannot be upgraded due to to high difference of version. Is there any solution for this?
> If you reply to this email, your message will be added to the discussion below:
> http://users.parboiled.org/maven-dependecy-conflict-tp4024114.html > To start a new topic under parboiled users, email [hidden email] > To unsubscribe from parboiled users, click here.